Учебное пособие Челябинск Издательство юургу 2000 icon

Учебное пособие Челябинск Издательство юургу 2000



Смотрите также:
1   2   3   4   5   6   7   8
^

2. Работаем в Borland C++ (BC)

Цель занятий


Знакомство со средой BC, изучение основных возможностей редактора BC, компиляция, компоновка, запуск заданий, просмотр результатов, отладка.
^

Теоретические сведения и примеры


Ниже рассматриваются клавиши быстрого управления среды BC (табл.2.1), команды текстового редактора среды (табл.2.2–2.5).

Таблица 2.1

^

Клавиши быстрого управления среды Borland C


Клавиши

Эквивалентная команда меню

Функция

1

2

3

F1




Вызвать контекстную помощь (Help)

F2

File/Save

Записать на диск редактируемый файл

F3

File/Open

Открыть файл для редактирования

F4

^ Run/Go to cursor

Выполнить программу до строки, с курсором

F5

Window/Zoom

Расширить окно до полного экрана (вернуть исходный размер окна)

F6

Window/Next

Активизировать следующее окно

F7

^ Run/Trace into

Трассировка с заходом в подпрограммы

F8

Run/Step over

Трассировка без входа в подпрограммы

F9

Compile/Make

Скомпилировать программу, начиная с основного файла

F10




Вызвать главное меню

Alt+F1

Help/Previous topic

Вывести предыдущее окно подсказки

Alt+F3

Window/Close

Закрыть окно

Alt+F5

Debug/User screen

Открыть окно пользователя

Alt+F7

Tools/Go to prev

Перейти к предыдущей строке окна сообщений

Alt+F8

Tools/Go to next

Перейти к следующей строке окна сообщений

Alt+F9

Compile/Compile

Скомпилировать программу

Alt+F10




Вызвать локальное меню

Окончание табл.2.1

1

2

3

Alt+BkSp

Edit/Undo

Отменить изменения в текущей строке

Alt+C




Вызвать меню Compile

Alt+D




Вызвать меню Debug

Alt+E




Вызвать меню Edit

Alt+F




Вызвать меню File

Alt+H




Вызвать меню Help

Alt+O




Вызвать меню Options

Alt+R




Вызвать меню Run

Alt+S




Вызвать меню Search

Alt+T




Вызвать меню Tools

Alt+W




Вызвать меню Window

Alt+X

File/Exit

Выйти из BC

Alt+0

Window/List

Вывести список открытых окон

Ctrl+F1

Help/Topic Screen

Осуществить предметный поиск

Ctrl+F2

Run/Program reset

Прекратить отладку программы

Ctrl+F3

Debug/Call stack

Показать окно вызванных подпрограмм

Ctrl+F4

Debug/Evaluate/ modyfy

Вычислить или модифицировать выражение

Ctrl+F5

Window/Size/Move

Изменить размеры окна, переместить

Ctrl+F7

Debug/Add watshes

Добавить выражения для просмотра

Ctrl+F8

Debug/Toggle breakpoint

Задать (снять) точку останова

Ctrl+F9

Run/Run

Выполнить программу

Ctrl+Del

Edit/Clear

Удалить блок

Ctrl+Ins

Edit/Copy

Копировать блок в буфер Clipboard

Shift+F1

Help/Index

Вывести словарь контекстной помощи

Shift+F6

Window/Previos

Активизировать предыдущее окно

Shift+Del

Edit/Cut

Перенести блок в буфер Clipboard

Shift+Ins

Edit/Paste

Копировать блок из буфера Clipboard

Esc




Выход из меню, информационного окна

Таблица 2.2

^

Команды передвижения курсора


На символ влево

Ctrl–S или ВЛ

На символ вправо

Ctrl–D или ВП

На слово влево

^ Ctrl–A Ctrl–ВЛ

На слово вправо

Ctrl–F Ctrl–ВП

На строку вверх

Ctrl–E или ВВ

На строку вниз

Ctrl–X или ВН

Прокрутка вверх

Ctrl–W

Прокрутка вниз

Ctrl–Z

Страница вверх

^ Ctrl–R или PgUp

Страница вниз

Ctrl–C или PgDn

Предыдущая позиция

Ctrl–Q P

В начало строки

Ctrl–Q S или HOME

В конец строки

Ctrl–Q D или END

В начало экрана

Ctrl–Q E или Ctrl–HOME

В конец экрана

Ctrl–Q X или Ctrl–END

В начало файла

Ctrl–Q R или Ctrl–PgUp

В конец файла

Ctrl–Q C или Ctrl–PgDn

В начало блока

Ctrl–Q B

В конец блока

Ctrl–Q K



Таблица 2.3


Команды вставки и удаления

Режим вставки вкл./выкл .

^ Ctrl–V или Ins

Вставить строку

Ctrl–N

Вставить опции

Ctrl–O O

Удалить строку

Ctrl–Y

Удалить до конца строки

Ctrl–Q Y

Удалить символ слева

^ Ctrl–H или Пробел

Удалить символ

Ctrl–G или Del

Удалить слово справа

Ctrl–T

Удалить блок

Ctrl–K Y


Таблица 2.4


Команды работы с блоками

Пометить начало блока

Ctrl–K B

Пометить конец блока

Ctrl–K K

Пометить одно слово

Ctrl–K T

Скопировать блок

Ctrl–K C

Перенести блок

Ctrl–K V

Удалить блок

Ctrl–K Y

Считать блок с диска

Ctrl–K R

Записать блок с диска

Ctrl–K W

Убрать/высветить блок

Ctrl–K H

Напечатать блок

Ctrl–K P

Раздвинуть блок

Ctrl–K I

Сжать блок

Ctrl–K U

Скопировать блок в буфер

Ctrl–Ins

Перенести блок в буфер

Shift–Del

Перенести блок из буфера

Shift–Ins


Таблица 2.5


Управляющие команды

Выйти из редактора без сохранения

Ctrl–K D или Ctrl–K Q

Сохранить и редактировать

Ctrl–K S или F2

Загрузить новый файл

F3

Табуляция

^ Ctrl–I или Tab

Режим табуляции

Ctrl–O T

Автораздвижка вкл./выкл.

Ctrl–O I

Восстановить строку

Ctrl–Q L

Установить маркер места

Ctrl–K n

Найти маркер места

Ctrl–Q n

Сравнение пар вправо

Ctrl–Q [

Сравнение пар влево

Ctrl–Q ]

Префикс управляющего символа

Ctrl–P

Восстановить сообщение об ошибке

Ctrl–Q W

Поиск

Ctrl–Q F

Поиск и замена

Ctrl–Q A

Повторить последний поиск

Ctrl–L
^

Задания для самостоятельного выполнения

Задание 2.1


1. Создать в редакторе файл NUMBER.CPP .

2. Ввести программу, которая «задумывает» три числа (5, 7, 9), которые

требуется угадать.


#include

void main(void)

{ int i=0, a;

do { puts(“Введите число от 0 до 9”);

scanf(“%d”,&a); i++; }

while (((a==5)||(a==7)||(a==9) ==0);

printf(“Вы угадали число с %d–го раза/n”,i);

}


3. Осуществить компиляцию, компоновку и выполнение программы.

4. Сохранить исходный модуль под именем NUMBER1.

5. Выйти из BC, запустить программу.

6. Загрузить BC, изменить в программе задуманные числа. Выполнить.

Задание 2.2


1. Создать в редакторе файл NAME.CPP.

2. Ввести, осуществить компиляцию, компоновку и выполнение программы.


#include

void main (void)

{ char name[15];

char *mname;

puts(“Как Вас зовут ?”);

scanf(“%s”,name);

mname=“Здравствуйте, ”;

printf(“%s%s”,mname,name);

}


3. Сохранить программу под текущим именем.

4. Изменить программу таким образом, чтобы она запрашивала фамилию.

5. Сохранить модифицированную программу под именем FAM.CPP.

6. Объединить две программы в одну, интересующуюся именем и фамилией (используя блоковые команды).

Задание 2.3


1. Создать в редакторе файл CLASS.CPP.

2. Ввести, осуществить компиляцию, компоновку и выполнение программы.


#include

void main (void)

{ int ans;

puts(“ Проверим знания по математике. ”);

puts(“ Сколько будет 22 ?”);

scanf(“%d”, &ans);

if (ans= =4)

puts(“Гениально!”);

else

if (ans>2&&ans<6)

puts(“Неплохо для начала.”);

else

puts(“А вы хорошо подумали?”);

}


3. Сохранить отлаженную программу под текущим именем.

4. Изменить вопрос и «комментарии» в программе.

5. Сохранить модифицированную программу под именем CLASS1.CPP.

6. Объединить программы в одну, задающую два вопроса (блоковые команды).

Задание 2.4


1. Создать в редакторе файл MAXMIN .

2. Ввести программу нахождения максимального (ymax) и минимального (ymin) значения из двух чисел. Скомпилировать, скомпоновать, выполнить.


#include

void main (void)

{ int a,b,ymax,ymin;

puts(“Введите два числа.”);

scanf(“%d %d”,&a,&b);

ymax=(a>b)?a:b;

ymin=(a

printf(“ymax=%d;\t ymin=%d;\n”,ymax,ymin);

}


3. Вставить в программу комментарии, описывающие функцию каждого

оператора. Организовать печать текста: «Всё — конец». Выполнить.

4. Сохранить исходный модуль под именем MINMAX.

Задание 2.5


1. Создать в редакторе файл DATA.CPP.

2. Ввести, осуществить компиляцию, компоновку и выполнение программы.


#include

void main (void)

{ int data;

puts(“ Какое сегодня число ?. ”);

scanf(“%d”, &data);

printf(“ Сегодня %d сентября.\n”,data);

printf(“ Вчера было %d сентября.\n”,data-1);

printf(“ Завтра будет %d сентября.\n”,data+1);

}


3. Сохранить отлаженную программу под текущим именем.

4. Изменить программу (использовать блоковые команды), добавив
« Позавчера … » и « Послезавтра … ».

5. Сохранить модифицированную программу под именем DATA1.CPP.

Задание 2.6


1. Дополнить до программы:


printf(“ Данные типа int занимают %d байт.\n”, sizeof(int));


2. Скомпилировать, скомпоновать, выполнить программу. Сохранить исходный модуль под именем SIZE.

3. Используя блоковые команды редактора, модифицировать программу таким образом, чтобы она сообщала информацию:

  1. обо всех целых типах данных;

  2. о типах данных, занимающих памяти столько же, сколько int;

  3. обо всех вещественных типах;

  4. о типах данных, занимающих памяти столько же, сколько long;

  5. обо всех знаковых типах;

  6. обо всех беззнаковых типах;

  7. обо всех типах данных, занимающих не меньше 4 байт памяти;

  8. обо всех типах данных.

4. Сохранить модифицированный вариант под именем SIZEALL.
^

Задание 2.7 (работа с текстовым редактором — блоковые команды)


1. Заполнить экран текстом


Институт Институт . . . . . . . . . . . . . . . . . . . .Институт

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .


— всего 32 строки по 8 «слов».

2. Удалить строки с 3–й по 25–ю включительно.

3. В конце вставить строчку Информатика.

4. По центру оставшейся части вставить строки с Ф.И.О. членов бригады.

Список предварительно создается в файле FIO.TXT.
^

Задание 2.8 (работа с отладчиком)


1. Ввести, отладить программу вычисления факториала — N!:


#include

/* Вычисление факториала */

void main (void)

{ unsigned p=1;

int N, n=0;

puts(“Введите N ”);

scanf(“%d”,&N);

while(++n<=N)

p*=n;

printf(“%d факториал = %u\n”,N,p);

}


2. Не меняя программу (с помощью отладчика), ответить:

  1. факториал какого наименьшего числа 1000?

  2. для какого наибольшего числа N возможно вычисление?

3. Изменить программу, чтобы она работала с большими числами.

4. Изменить программу, чтобы она печатала значение факториала на каждом шаге (1!, 2!, 3!, … , N!).

^

Задание 2.9 (работа с отладчиком)


1. Ввести, отладить приведённую ниже программу деления на 2.

2. Разделить числа 1024, 2048, 2400. Проверить правильность деления с помощью отладчика.

  1. Исправить программу так, чтобы она выдавала правильный результат.


#include

/* деление на 2 */

void main (void)

{ unsigned N;

puts(“Делю на 2”);

puts(“Введите целое число N>0 ”);

scanf(“%u”,&N);

N/=2;

N/=2;

N/=2;

N/=2;

N/=2;

N/=2;

N/=2;

N/=2;

N/=2;

printf(“Результат 9 делений на 2 равен %u\n”,N);

}

^

Задание 2.10 (работа с отладчиком)


1.Ввести, отладить программу суммирования натуральных чисел от 1 до N.


#include

/* Суммирование натуральных чисел */

void main (void)

{ unsigned S=0;

int N,n=1;

puts(“Введите четное N”);

scanf(“%d”,&N);

for(n=1;n<=N;n++)

S+=n;

printf(“Сумма чисел от 1 до %d равна %u\n”,N,S);

}


2. Не меняя программу (с помощью отладчика), найти сумму чисел от 1 до [N/2] и сумму чисел от ([N/2]+1) до N.

3. Изменить программу, чтобы она вычисляла и печатала сумму чисел от 1 до [N/2] и сумму чисел от ([N/2]+1) до N.




страница2/8
Дата конвертации01.04.2013
Размер0,66 Mb.
ТипУчебное пособие
1   2   3   4   5   6   7   8
Разместите кнопку на своём сайте или блоге:
rud.exdat.com


База данных защищена авторским правом ©exdat 2000-2012
При копировании материала укажите ссылку
обратиться к администрации
Документы