Программа Microsoft Access, входящая в состав пакета Microsoft Office, относится к классу систем управления базами данных субд icon

Программа Microsoft Access, входящая в состав пакета Microsoft Office, относится к классу систем управления базами данных субд



Смотрите также:
Microsoft Access 2003

Работа № 1

Основные понятия реляционных баз данных

Создание таблиц в Microsoft Access.

Цель работы: Знакомство с основными понятиями управления базами данных,
структуре и приемами формирования их при работе в Microsoft Access.
Создание учебной базы данных. Знакомство с основными приемами работы конструктора базы данных. Ввод данных в табличном режиме.


НАЗНАЧЕНИЕ СИСТЕМ УПРАВЛЕНИЯ БАЗАМИ ДАННЫХ.

Программа Microsoft Access, входящая в состав пакета Microsoft Office, относится к классу систем управления базами данных - СУБД.
СУБД предназначены для создания баз данных и обеспечения доступа к ним.
База данных (БД) – это совокупность особым образом упорядоченных данных, описывающих какие-либо объекты. В качестве примера баз данных, существующих в бумажном виде, можно привести библиотечный каталог и данные о пациентах в регистратуре больницы. Эти базы данных содержат информацию об однотипных объектах – книгах и пациентах. СУБД значительно облегчают работу с базами данных, хотя этап наполнения базы данных является, как и в случае с неавтоматизированными базами данных, самым трудоёмким этапом. Доступ к базе данных подразумевает возможность извлечения из неё информации, удовлетворяющей задаваемым пользователем критериям. Доступ к неавтоматизированным базам данных возможен только в соответствии со способом упорядочения носителей информации. Например, в библиотечном каталоге поиск осуществляется только по алфавитному каталогу авторов книг.

Компьютерные СУБД предоставляют возможность упорядочения данных в базах данных и доступа к ним практически любыми способами.

СУБД бывают разных типов – реляционные, сетевые, объектно-ориентированные. От типа СУБД зависит, как связаны между собой данные, составляющие базу данных. MS Access относится к реляционным СУБД. В них база данных состоят из отдельных таблиц, хранящих информацию об однотипных объектах. Для знакомства с Access мы создадим простую базу данных. Чтобы сделать это, сначала необходимо рассмотреть основные понятия реляционных баз данных.


^ 2. РЕЛЯЦИОННЫЕ БАЗЫ ДАННЫХ.

Реляционная база данных – это связанная информация, представленная в виде двумерных таблиц.

Представьте себе адресную книгу. Она содержит множество строк, каждая из которых соответствует данному индивидууму. Для каждого из них в ней представлены некоторые независимые данные, например, имя, номер телефона, адрес. Представим такую адресную книгу в виде таблицы, содержащей строки и столбцы. Каждая строка (называемая также записью) соответствует определенному индивидууму, каждый столбец содержит значения соответствующего типа данных: имя, номер телефона и адрес, – представленных в каждой строке.

Адресная книга может выглядеть таким образом:

Имя

Телефон

Адрес

Яншин Алексей

(095)570-12-15

Москва, пр. Космонавтов, 35, 72

Калинин Василий

(127)5-35-53

Апатиты, ул. Северная, 2б 17

Маслов Евгений

(261)12-15-65

Коломна, ул. Весенняя, 127б 35


То, что мы получили, является основой реляционной базы данных, определенной в начале нашего обсуждения двумерной (строки и столбцы) таблицей. Однако, реляционная база данных редко состоит из одной таблицы, которая слишком мала по сравнению с базой данных.

При создании нескольких таблиц со связанной информацией можно выполнять более сложные и мощные операции над данными. Мощность базы данных заключается, скорее, в связях, которые вы конструируете между частями информации, чем в самих этих частях.


2.1. Установление связи между таблицами.

Давайте используем пример адресной книги для того, чтобы обсудить базу данных, которую можно реально использовать в деловой жизни. Предположим, что индивидуумы первой таблицы являются пациентами больницы. Дополнительную информацию о них можно хранить в другой таблице. Столбцы второй таблицы могут быть поименованы таким образом: Пациент, Врач, Дата последнего обращения.


Пациент

Врач

Дата последнего обращения

Яншин

Быстров

15/03/92

Маслов

Ястребов

21/11/97

Калинин

Ястребов

10/06/96


Можно выполнить множество функций при извлечении информации из этих таблиц в соответствии с заданными критериями, особенно, если критерий включает связанные части информации из различных таблиц. Предположим, врач Ястребов желает получить номера телефонов всех своих пациентов. Для того, чтобы извлечь эту информацию, он должен связать таблицу с номерами телефонов пациентов (адресную книгу) с таблицей, определяющей его пациентов. В данном простом примере он может мысленно проделать эту операцию и узнать телефонные номера своих пациентов Маслова и Калинина, в действительности же эти таблицы вполне могут быть больше и намного сложнее.

СУБД, обрабатывающие реляционные базы данных, были созданы для работы с большими и сложными наборами тех данных, которые являются наиболее общими в деловой жизни общества. Даже если база данных больницы содержит десятки или тысячи имен (как это, вероятно, и бывает в реальной жизни), с помощью нескольких команд СУБД можно получить необходимую информацию практически мгновенно.


2.2. Порядок строк в таблице.

Для обеспечения максимальной гибкости при работе с данными строки таблицы, по определению, никак не упорядочены. Этот аспект отличает базу данных от адресной книги. Строки в адресной книге обычно упорядочены по алфавиту. Одно из мощных средств, предоставляемых реляционными СУБД, состоит в том, что пользователи могут упорядочивать информацию по своему желанию.

Рассмотрим вторую таблицу. Содержащуюся в ней информацию иногда удобно рассматривать упорядоченной по имени пациента, иногда – в порядке возрастания или убывания даты, а иногда – сгруппированной по имени врача. Внушительное множество возможных порядков строк помешало бы пользователю проявить гибкость в работе с данными, поэтому строки предполагаются неупорядоченными. Именно по этой причине вы не можете просто сказать: "Меня интересует пятая строка таблицы". Независимо от порядка включения данных или какого-либо другого критерия, этой пятой строки не существует по определению. Итак, строки таблицы предполагаются расположенными в произвольном порядке.


2.3. Идентификация строк (первичный ключ).

По этой и ряду других причин, необходимо иметь столбец таблицы, который однозначно идентифицирует каждую строку. Обычно этот столбец содержит номер, например, приписанный каждому пациенту. Конечно, можно использовать для идентификации строк имя пациента, но ведь может случиться так, что имеется несколько пациентов с именем "Иванова Мария". В подобном случае нет простого способа их различить, именно по этой причине обычно используются номера.

Такой уникальный столбец (или их группа), используемый для идентификации каждой строки и обеспечивающий различимость всех строк, называется первичным ключом таблицы.

Первичный ключ таблицы – жизненно важное понятие структуры базы данных. Он является сердцем системы данных: для того чтобы найти определенную строку в таблице, укажите значение ее первичного ключа. Кроме того, он обеспечивает целостность данных. Если первичный ключ должным образом используется и поддерживается, вы будете твердо уверены в том, что ни одна строка таблицы не является пустой и что каждая из них отлична от остальных.

2.4. Наименование столбцов.

В отличие от строк, столбцы таблицы (также называемые полями) упорядочены и поименованы.

Следовательно, в нашей таблице, соответствующей адресной книге, можно сослаться на столбец "Адрес" как на "столбец номер три". Естественно, это означает, что каждый столбец данной таблицы должен иметь имя, отличное от других имен, для того, чтобы не возникло путаницы. Лучше всего, когда имена определяют содержимое поля. Access позволяет использовать русские слова в названиях полей, поэтому в учебной базе данных мы будем использовать такие названия полей, как "Имя" или "Дата рождения". Предположим также, что таблица содержит единственный цифровой столбец, используемый как первичный ключ.

^ 3. УЧЕБНАЯ БАЗА ДАННЫХ.

Таблицы 1, 2, 3, 4, 5, образуют реляционную базу данных. На ее примере покажем основные приемы работы с MS Access. Можно заметить, что первый столбец в первой таблице содержит номера, не повторяющиеся от строки к строке в пределах таблицы. Как вы, наверное, догадались, это первичные ключи таблицы. Некоторые из этих номеров появляются также в столбцах других таблиц (в этом нет ничего предосудительного), что указывает на связь между строками.

^ Таблица 1. Список.




Таблица 2. Паспорт.




^ Таблица 3.Образование.





Таблица 4. Дети.




^ Таблица 5.Оплата




Вы узнали, что понятие "запись" является синонимом понятия "строка" и что понятие "поле" является синонимом понятия "столбец".

Теперь перейдем к непосредственной работе с MS Access. В данной лабораторной работе вы должны будете создать учебную базу данных.


3.1. Создание учебной базы данных в Microsoft Access-2003.

1) Запустите программу Microsoft Access (Пуск, Все программы, Microsoft Office, Microsoft Office Access 2003).

2) Сразу после запуска Microsoft Access-2003 на экране появится диалоговое окно входа в Microsoft Access с предлагаемыми вариантами работы с базами данных (созданием новой базы данных или с открытием уже имеющейся базы данных).

3) Выберите левой кнопкой мыши в меню «Файл» команду «создать», а затем на панели задач «Создание файла» выбираем «Новая база данных». При этом открывается диалоговое окно «Файл новой базы данных» (рис. 1).



Рис. 1.

4) Выберите папку, в которой будет храниться файл с Вашей базой данных, а в поле ввода "Имя файла" укажите имя файла своей базы данных. Щелкните левой кнопкой мыши в поле "Имя файла" и с клавиатуры наберите имя УчБД затем наберите свою фамилию (расширение указывать не надо!). А затем выполните щелчок по кнопке «Создать».
Microsoft Access 2003 хранит все таблицы базы данных, а также некоторую дополнительную информацию – например, запросы, формы просмотра, печатные отчеты, в одном файле с расширением "mdb".

Примечание: если Ваше имя файла совпадет с именем другого файла, программа выдаст сообщение о том, что файл с таким именем уже существует и предложит заменить его. Выберите вариант ответа – Нет. В этом случае Вам придется изменить имя своего файла, т.е. добавить/удалить хотя бы один символ в названии, например инициалы.

5) Теперь на экране откроется окно (рис. 2) созданной Вами базы данных с присвоенным именем, например: "УчБД Иванова: база данных"




Рис. 2.

В этом окне перечисляются объекты, составляющие базу данных. Кроме таблиц, в Access в базе данных хранятся объекты, облегчающие наполнение базы данных, извлечение из нее информации и организацию управления данными.
Например, Таблицы, Запросы, Формы, Отчеты, Макросы, Модули.
Для объектов каждого типа слева в окне имеется ярлычок. На рис. 2 выбрана (активна) закладка "Таблицы".

^ 3.2. Создание таблиц.

Только что созданная база данных, естественно, пуста. Необходимо ввести в нее первоначальные данные. Т.к. данные представлены в табличном виде, создадим в базе данных таблицу 1 Список, таблицу 2 Паспорт, таблицу 3 Образование, таблицу 4 Дети, таблицу 5 Оплата.

Самым простым способом создания деловых и личных таблиц является использование мастера по разработке таблиц. Сначала мастер по разработке таблиц предлагает пользователю выбрать образец таблицы (например, "Контакты", "Имущество" или "Рецепты"), потом задает вопросы о полях, которые следует разместить в новой таблице, а затем создает указанную таблицу. Кроме того, пользователь может создать таблицу самостоятельно, без помощи мастера по разработке таблиц.


Чтобы создать таблицу с помощью мастера по разработке таблиц:

1. Находясь в окне базы данных, укажите на корешок «Таблица» и выполните щелчок.

2. Выполните щелчок на корешке "Создать".

3. На экране появится окно диалога «Новая таблица». Выберите «Мастер таблиц» и выполните щелчок на кнопке «ОК».

В окне диалога «Создание таблиц» выберите образец таблицы, а затем добавьте в нее образцы полей, в соответствии с инструкциями, содержащимися в окне диалога «Создание таблиц».

После того как таблица будет создана, следует выбрать режим открытия таблицы: режим конструктора, в котором можно просмотреть и изменить макет таблицы, или режим таблицы, предназначенный для просмотра и ввода табличных данных. Кроме того, можно создать новую форму, предназначенную для просмотра, изменения, добавления, удаления табличных данных.


^ Чтобы создать таблицу без помощи мастера по разработке таблиц:

1. Находясь в окне базы данных, укажите на корешок "Таблица" и выполните щелчок.



Рис. 3.

2. Нажмите кнопку "Создать". На экране появится окно диалога «Новая таблица».

3. Укажите на корешок «Конструктор» и выполните щелчок.

На экране появится пустое окно таблицы в режиме конструктора.


Примечание Кроме того, можно создать таблицу, импортировав данные из другого приложения, или присоединить к своей базе данных внешнюю таблицу. Например, с помощью команды Импорт можно создать таблицу Microsoft Access, импортировав в нее данные из таблицы dBASE или Paradox.


^ Окно таблицы в режиме конструктора

Верхняя часть окна таблицы в режиме конструктора содержит описание полей таблицы, а в нижней части отображаются свойства поля. Свойства полей подробно рассматриваются далее.



Рис. 4.

^ Добавление полей

Записи в таблице могут содержать несколько элементов информации. Для хранения каждого элемента информации в таблицу должно быть добавлено отдельное поле. Например, таблица, предназначенная для хранения сведений о сотрудниках, может содержать поля для фамилии, адреса и номера телефона сотрудника.

Создание таблицы начинается с ввода сведений о полях в верхнюю часть окна таблицы. В каждую строку необходимо ввести имя поля и выбрать для него тип данных. Кроме того, можно включить необязательное описание, которое отображается в строке состояния при вводе данных в это поле.


^ Использование построителя полей

Если вы не знаете, какое имя или тип данных следует выбрать для поля, то, возможно, вам будет проще сделать выбор из готового списка полей. С помощью построителя полей можно сделать выбор из того же списка образцов полей, что и при работе с мастером по разработке таблиц. В этот список включены поля из таблиц "Контакты", "Имущество", "Рецепты" и т.п.


^ Чтобы добавить поле с помощью построителя полей:

1. Находясь в окне таблицы, установите указатель в строку, в которую следует добавить поле, и выполните щелчок.

2. Нажмите правую кнопку мыши, чтобы вывести на экран контекстное меню, а затем выберите Построить (или нажмите кнопку "Построить" на панели инструментов).

3. Выделите таблицу в списке "Образцы таблиц".

4. Выделите имя поля в списке "Образцы полей".

5. Нажмите кнопку "ОК".

Microsoft Access вставит указанное имя поля в текущую строку в окне таблицы, выберет тип данных, пригодный для этого поля, и установит используемые по умолчанию свойства поля. Если текущая строка уже содержит описание поля, то для описания указанного поля будет вставлена новая строка.


^ Присвоение имени

Добавление поля начинается с ввода его имени в столбец "Поле". Имена полей могут содержать буквы, цифры и пробелы; их длина может достигать 64 символов.

Присвоение полям имен, кратко описывающих их содержание, - существенно упрощает ввод и изменение записей. Например, таблица "Сотрудники" может содержать поля с именами: "Фамилия", "Рабочий телефон" и "Домашний телефон".


Наличие пробелов в именах полей делает их более понятными и в большинстве случаев является предпочтительным, однако, такие имена полей не очень удобно использовать в выражениях, а также инструкциях на языке SQL или Access Basic.
Поэтому при создании базы данных, в которой планируется использовать перечисленные выше возможности, рекомендуется использовать более короткие имена полей, которые проще вводить и запоминать. Например, для упомянутой выше таблицы лучше выбрать поля "РТелефон" и "ДТелефон".


^ Выбор типа данных

После присвоения имени полю следует выбрать тип данных, для хранения которых предназначено это поле. При выборе типа данных следует дать ответ на следующие вопросы:

1. Значения какого рода будут храниться в этом поле. Например, нельзя хранить текст в поле, для которого выбран числовой тип данных.

2. Какой объем следует отвести для хранения каждого значения в этом поле. Например, любое значение в денежном поле занимает 8 байт.

3. Какие операции будут выполняться над значениями из этого поля. — Например, Microsoft Access может вычислить сумму числовых или денежных значений, но не сможет вычислить сумму текстовых или OLE-значений.

4. Планируется ли выполнять сортировку или индексацию значений в этом поле. Следует учесть, что Microsoft Access не может создавать индексы для МЕМО и OLE-полей.

По умолчанию для каждого поля автоматически выбирается текстовый тип данных. Для изменения типа поля следует выбрать нужный тип данных из списка в столбце "Тип данных" для этого поля.


Для хранения номеров телефона, почтовых индексов и других числовых данных, над которыми не планируется выполнять математические вычисления, рекомендуется использовать текстовые, а не числовые поля.

^ Для текстовых и числовых полей можно более конкретно указать размер или тип данных с помощью свойства "Размер поля"


Описание полей

Для упрощения понимания структуры таблиц и их обновления можно добавить описание для каждого поля таблицы. Например, если таблица содержит денежное поле с именем "Цена", то можно пояснить, что именно содержится в этом поле, введя "Текущая розничная цена за единицу товара" в столбец "Описание" для этого поля.

Описание поля отображается в строке состояния при вводе данных в это поле в режиме таблицы или в элементе управления, связанном с этим полем.


^ Свойства полей

Пользователь может управлять изображением данных, запретить ввод неправильных значений, определить значения, используемые по умолчанию, и ускорить выполнение поиска и сортировки, выбрав соответствующие значения свойств полей в режиме конструктора таблиц. Например, можно выбрать формат изображения чисел, улучшающий их восприятие, или указать, каким условиям должны удовлетворять значения, которые можно вводить в данное поле.

Microsoft Access использует свойства полей при просмотре и изменении данных. Свойства "Формат поля", "Маска ввода" и "Подпись поля" используются в таблицах и запросах в режиме таблицы; кроме того, элементы управления в новых формах и отчетах, основанных на данной таблице, наследуют эти свойства по умолчанию. Другие свойства, налагающие условия на значения в поле или указывающие, что данное поле обязано содержать значение, используются при вводе и изменении табличных данных.

Одновременно можно просмотреть и изменить свойства только для одного поля. Значения свойств, определенные для поля, выделенного в верхней части окна таблицы в режиме конструктора, отображаются в нижней части этого окна.


Для полей присоединенных таблиц можно определить только свойства "Формат поля", "Число десятичных знаков", "Маска ввода" и "Подпись поля". Остальные свойства не применимы к присоединенным таблицам. Однако свойства для полей присоединенных таблиц из другой базы данных Microsoft Access можно определить в исходной базе данных.


чтобы определить свойство поля в таблице:

  1. Откройте таблицу в режиме конструктора.

2. Выберете поле в верхней части окна таблицы, для которого следует определить свойства. Microsoft Access покажет свойства для текущего поля в нижней части окна таблицы. Набор свойств определяется типом данных, выбранным для этого поля.

3. Выберете ячейку в нижней части окна таблицы, соответствующую свойству, которое следует изменить.

4. Введите значение для этого свойства или, если в правой части ячейки находится кнопка раскрытия списка, нажмите ее, а затем выберите нужное значение из списка.

Для того чтобы увеличить размеры области для ввода или изменения значения свойства, нажмите клавиши SHIFT+F2. Для получения помощи при вводе маски ввода или выражения-условия нажмите кнопку "Построить", расположенную справа от соответствующей ячейки, чтобы вызвать нужный построитель.

5. Для сохранения изменений, внесенных в таблицу, выберите «Сохранить» в меню Файл (или нажмите кнопку "Сохранить" на панели инструментов).


^ Изменение порядка и удаление полей

Если пользователь решит, что структура таблицы содержит неправильные поля, он может изменить порядок полей или вообще удалить их из структуры таблицы.

^ Чтобы переместить поле:

1. Выделите строку с описанием поля: установите указатель в области маркировки поля слева от этого поля и нажмите кнопку мыши.

2. Перенесите эту строку на нужное место с помощью мыши.

Чтобы удалить поле:

1. Выделите строку с описанием поля, а затем нажмите клавишу DEL. (или выберите удалить в меню Правка).


^ Определение ключа

Эффективность работы Microsoft Access повышается при наличии в таблице ключа. Ключ таблицы состоит из одного или нескольких полей, совокупность значений которых однозначно определяет каждую запись этой таблицы.

Как правило, ключевым, назначается поле, которое содержит уникальный код или номер. Например, в таблице "Список" базы данных каждому сотруднику соответствует уникальный код, который хранится в поле "Код". Естественно, что в качестве ключа таблицы "Список" выбрано именно это поле.


Таблица, для которой определен ключ, называется индексированной. Индексированные таблицы обладают следующими преимуществами:

1. Microsoft Access автоматически создает индекс для ключевого поля (или совокупности ключевых полей). Наличие индекса существенно ускоряет выполнение запросов и некоторых других операций.

2. По умолчанию записи в форме или таблице изображаются в порядке, определяемом ключом.

3. Microsoft Access не допускает наличия в таблице записей с одинаковыми значениями ключа. По этой причине невозможно ввести в таблицу запись, у которой значение ключа совпадает со значением ключа одной из существующих записей, т.е. уникальность записей в таблице поддерживается автоматически.

4. Кроме того, наличие ключа необходимо для установки связей между таблицами и одновременного обновления нескольких связанных таблиц.


Примечание. При сохранении новой неиндексированной таблицы пользователю предлагается определить для нее ключ автоматически. В случае положительного ответа в таблицу будет добавлено новое поле - счетчик с именем "Код", которое будет содержать уникальное значение (порядковый номер) для каждой записи. Если в таблице уже есть поле- счетчик, то оно будет автоматически назначено ключевым.


^ Чтобы определить ключ:

1. Выделите строку с описанием нужного поля: установите указатель в области маркировки поля слева от этого поля и нажмите кнопку мыши. Для того чтобы создать составной ключ, нажмите клавишу CTRL и, не отпуская ее, выделите по очереди все нужные поля.

2. Выберите «Ключевое поле» в меню Правка (или нажмите кнопку «Ключевое поле» на панели инструментов). Microsoft Access добавит символ ключа слева от выделенного поля (или полей).

^ Использование составного ключа

Для большей части таблиц достаточно определить одно ключевое поле. Однако, если ни одно поле таблицы не содержит уникальных значений, можно определить ключ, состоящий из нескольких полей.


Предположим, что создается таблица для хранения сведений о распределении кабинетов. Первое поле этой таблицы содержит дату и время, а второе — номер кабинета. Ни одно из этих полей не содержит уникальных значений, однако, комбинация этих полей однозначно определяет каждую запись.

Для создания ключа, состоящего из этих двух полей, выделите оба поля (при нажатой клавише CTRL) в режиме конструктора таблиц, а затем нажмите кнопку "Определить ключ" на панели инструментов.

Теперь Microsoft Access сможет гораздо быстрее найти все сведения о распределении кабинетов за определенное число. Поскольку Microsoft Access не допускает наличия в таблице записей с одинаковыми значениями ключа, невозможно выдать ключ от одного кабинета одновременно двум сотрудникам.


^ Сохранение таблицы

После того как все поля таблицы будут определены, необходимо сохранить макет таблицы прежде, чем можно будет приступить к вводу записей. После сохранения таблицы ее имя появится в списке таблиц в окне базы данных.

При сохранении новой таблицы ей следует присвоить имя, описывающее ее содержимое. Имена таблиц могут содержать буквы, цифры и пробелы; их длина может достигать 64 символов. Например, таблицам можно присвоить имена "Клиенты", "Товары на складе" или "Розничные цены".


^ Чтобы сохранить таблицу и присвоить ей имя:

1. Выберите Сохранить в меню Файл.

2. Если сохраняется новая таблица, введите имя для нее, а затем нажмите кнопку "ОК".


^ Просмотр таблицы в режиме таблицы

В режиме конструктора таблиц можно определять поля и вносить другие изменения в макет таблицы. Для того чтобы получить возможность вводить, изменять и просматривать табличные данные, необходимо перейти в режим таблицы. Находясь в окне базы данных, можно открыть таблицу в любом из этих двух режимов. Для переключения режима просмотра открытой таблицы следует выбрать Конструктор или Режим таблицы в меню Вид (или нажать кнопку "Конструктор" или "Режим таблицы" на панели инструментов).


^ Ввод записей

Для того чтобы получить возможность приступить к вводу записей в таблицу (после того как она будет создана), следует нажать кнопку "Режим таблицы" на панели инструментов. На экране появится окно таблицы в режиме таблицы, в котором поля и записи изображаются в табличном формате (в виде столбцов и строк).


После сохранения и закрытия таблицы можно снова открыть таблицу в режиме таблицы для просмотра или изменения записей. Для этого достаточно указать на имя таблицы в окне базы данных и выполнить двойной щелчок мыши.


^ Создадим таблицы

1) Для добавления в базу данных новой таблицы мышью выберите (активизируйте) Таблицы и нажмите в верхней части окна Вашей базы данных кнопку «Создать» (рис. 2).

2) Появится окно "Новая таблица" (рис. 3) правая часть которого отображает перечень

способов создания таблицы.

3) Выберите из перечня Конструктор, затем нажмите кнопку OK.

Откроется окно Таблица1: таблица (рис. 5) в котором надо описать структуру (макет) новой таблицы «Список»: введите название первого поля «Код», затем выбираем тип данных «Счётчик» и в поле описание введём «Код сотрудника», в свойстве индексированное поле выберем значение «Да (Совпадения не допускаются)», определите первичный ключ – ключевое поле.



Рис. 5.

Аналогично добавим остальные поля, определим для них тип данных и свойства в соответствии с таблицей.

Примечание. В столбце свойства поля указаны только те свойства которые должны быть определены.

Таблица1 Список.

Имя поля

Тип данных

^ Свойства поля

Код

Счётчик

Индексированное поле – Да (совпадения не допускаются)

Фамилия

Текстовый

Размер поля – 25, Индексированное поле – Да (допускаются совпадения)

Имя

Текстовый

Размер поля – 15,

Отчество

Текстовый

Размер поля – 25,

Дата рождения

Дата/Время

Формат поля –Краткий формат даты, Маска ввода – Краткий формат даты.

Отдел

Текстовый

Размер поля – 25, Поле со списком (Введите фиксированный набор значений).

Член профсоюза

Логический

Формат поля – Да/Нет

Домашний телефон

Текстовый




Рабочий телефон

Текстовый




Характеристика

МЕМО




Фотография

Поле объекта OLE





4) Сохраним созданный макет таблицы в базе данных и, кроме того, присвоим ему имя "Список". Пока она называется "Таблица1". Это имя, присвоено новой таблице "по умолчанию". Для этого в меню «Файл» выполним команду «сохранить». А затем в диалоговом окне «Сохранение» введём имя созданной таблицы «Список». Закройте окно конструктора таблицы.

Теперь Ваша база данных состоит из одной таблицы «Список», но она пока не заполнена данными.

5) В окне "База данных" теперь появится таблица "Список". Переименовать или удалить таблицу можно в этом окне, щелкнув правой кнопкой на ее имени и выбрав соответствующую команду в контекстном меню. Посмотрите, как выглядит это меню, но не выбирайте никаких команд (чтобы убрать контекстное меню, достаточно нажать на клавиатуре клавишу «Esc» или щелкнуть левой кнопкой вне меню). Кнопка "Конструктор" в окне "База данных" позволяет перейти в окно конструктора таблиц и внести изменения в ее структуру (при этом предварительно необходимо выбрать ту таблицу структуру которой необходимо изменить). Попробуйте нажать кнопку "Конструктор" и просмотреть описание таблицы "Список".

6) Для ввода данных в таблицу «Список» необходимо перейти из окна конструктора таблиц в режим таблица. Выполните в меню «Вид» команду «Режим таблицы».

Аналогичным образом создайте макеты для остальных таблиц в соответствии с приведёнными ниже таблицами.

Таблица2 Паспорт.

Имя поля

Тип данных

^ Свойства поля

Код сотрудника

Числовой

Индексированное поле – Да (совпадения не допускаются)

Серия

Текстовый

Размер поля – 5

Номер

Текстовый

Размер поля – 6,

Код подразделения

Текстовый

Размер поля – 7,

Дата выдачи

Дата/Время

Формат поля – Краткий формат даты, Маска ввода – Краткий формат даты.

Регистрация

Текстовый

Размер поля – 80,

Семейное положение

Текстовый

Размер поля – 10,
Поле со списком (Введите фиксированный набор значений).


Таблица3 Образование.

Имя поля

Тип данных

^ Свойства поля

Код сотрудника

Числовой

Индексированное поле – Да (совпадения не допускаются)

Образование

Текстовый

Размер поля – 20,
Поле со списком (Введите фиксированный набор значений).

Учебное заведение

Текстовый

Размер поля – 70,

Специальность

Текстовый

Размер поля – 25,

Квалификация

Текстовый

Размер поля – 25,

Дата окончания

Дата/Время

Формат поля – Краткий формат даты, Маска ввода – Краткий формат даты.

Номер, серия диплома

Текстовый

Размер поля – 20,

Семейное положение

Текстовый

Размер поля – 15,
Поле со списком (Введите фиксированный набор значений).


Таблица4 Дети.

Имя поля

Тип данных

^ Свойства поля

Код сотрудника

Числовой

Индексированное поле – Да (допускаются совпадения).

Фамилия

Текстовый

Размер поля – 20.

Имя

Текстовый

Размер поля – 15,

Отчество

Текстовый

Размер поля – 25,

Дата рождения

Дата/Время

Формат поля – Краткий формат даты, Маска ввода – Краткий формат даты.

Пол

Текстовый

Размер поля – 10,
Поле со списком (Введите фиксированный набор значений).


Таблица5 Оплата.

Имя поля

Тип данных

^ Свойства поля

Код

Числовой

Индексированное поле – Да (допускаются совпадения).

Год

Текстовый

Значение по умолчанию - 2010

Месяц

Текстовый

Размер поля – 10,
Поле со списком (Введите фиксированный набор значений).

Оплата

Денежный

Формат поля – Денежный,
Число десятичных знаков – 2.


Контрольные вопросы

  1. Типы данных.

  2. Свойства полей таблицы.

  3. Какие поля могут быть ключом таблицы.


Работа № 2

Установка связей между таблицами


Поскольку Microsoft Access является системой управления реляционными базами данных, он может одновременно использовать данные из нескольких таблиц или запросов. При наличии в базе данных таблиц со связанными данными пользователь может установить связи внутри базы данных. Microsoft Access использует связи для:


  • ^ Объединения таблиц в запросах. При добавлении в запрос связанных таблиц и запросов установленные между ними связи используются для их автоматического объединения.

  • ^ Отображения связанных записей в подчиненных формах и отчетах. Обычно подчиненные формы и отчеты используются для отображения записей из связанных таблиц. При размещении формы или отчета в другой форме или отчете установленные между ними связи используются для отбора данных, которые следует отображать в подчиненной форме или отчете

  • ^ Поддержания целостности данных, т.е. сохранения существующих межтабличных связей при вводе, изменении и удалении записей.


Для того чтобы установить связь между таблицами или запросами, следует указать одно или несколько полей, которые содержат одинаковые значения в связанных записях. Довольно часто эти поля имеют одинаковые имена в обеих таблицах; в большинстве случаев одно из этих полей является ключевым полем своей таблицы. Например, в таблицу, содержащую сведения о детях, может быть включено поле для хранения сведений о сотруднике (родителе). Для того чтобы установить связь между таблицами "Сотрудники" и "Дети", следует указать Microsoft Access, что поле "Код" в таблице "Дети" содержит те же значения, что и одноименное поле, являющееся ключом таблицы "Сотрудники". Для создания, просмотра и изменения связей предназначено окно "Схема данных".


^ Установка связи

Только что созданная таблица, не связана ни с какой другой таблицей. Установка связи начинается с открытия окна "Схема данных" и выбора таблиц или запросов, между которыми следует установить связь. После этого можно приступить к установке связи.


^ Чтобы открыть окно "Схема данных":

  1. Находясь в окне базы данных, выберите Схема данных в меню Сервис (или нажмите кнопку "Схема данных" на панели инструментов).

Если вы ранее просматривали или изменяли связи, то окно диалога будет содержать последнюю сохраненную вами схему данных. При первом открытии этого окна диалога для текущей базы данных оно будет пусто, а Microsoft Access откроет окно "диалога Добавление таблицы.


^ Чтобы добавить таблицы или запросы в окно "Схема данных":

    1. Если окно диалога Добавление таблицы не появится на экране автоматически, выберите «Добавить таблицу» в меню «Связи» (или нажмите кнопку "Добавить таблицу").

    2. В списке "Таблица/запрос" выделите таблицу (или запрос), для которой следует установить связь, а затем нажмите кнопку "Добавить".
      Для выделения сразу нескольких таблиц или запросов следует нажать клавишу CTRL и, не отпуская ее, выделить по очереди все нужные объекты. Для выделения всех объектов или непрерывной группы объектов следует выделить первый объект, а затем нажать клавишу SHIFT и, не отпуская ее, выделить последний объект.


^ Чтобы установить связь:

  1. С помощью мыши перенесите поле, которое следует использовать для установки связи, из списка полей одной таблицы (или запроса) к соответствующему полю в списке полей другой таблицы (или запроса). Если одно из связанных полей является ключевым, переносить следует его (ключевые поля в списке полей выделяются полужирным начертанием).

Поле, которое было перенесено, принадлежит главной таблице; вторая таблица называется подчиненной.

На экране появится окно диалога «Изменение связей». Проверьте правильность имен полей в обоих столбцах и измените их, если требуется.




  1. Выберите параметры связи.

  2. Нажмите кнопку «ОК».

Microsoft Access установит указанную связь и проведет линию между связанными полями в двух списках полей. Эта связь останется в базе данных до тех пор, пока не будет явно удалена.


При закрытии окна "Схема данных" пользователю предлагается сохранить изменения макета в этом окне. Если эти изменения будут сохранены, то при следующем открытии содержимое окна "Схема данных" будет восстановлено. Все это влияет только на содержимое окна "Схема данных"; новые и измененные связи в базе данных сохраняются в базе данных.


  1. Добавте в окно «Схема данных» все созданные таблицы.

  2. Установите связь между таблицей «Список» и таблицей «Дети»

  3. В окне «Изменение связей» включите опции: «Обеспечение целостности данных», «Каскадное удаление связанных записей».

  4. Выполните щелчок по кнопке «Объединение…». И в окне «Параметры объединения» выберете 2 тип объединения

  5. Выполните щелчок по кнопке «ОК»

  6. В окне «Изменение связей» Выполните щелчок по кнопке «Создать».


Аналогичным образом установите связь между таблицей «Список» и остальными таблицами.




^ Просмотр и изменение существующих связей

Пользователь может просмотреть связи, установленные в своей или чужой базе данных, а также изменить существующие связи в своей базе данных. Например, можно установить для связи поддержание целостности данных или вообще удалить ставшие ненужными связи из базы данных.

При добавлении связанных таблиц или запросов в окно "Схема данных" Microsoft Access автоматически изображает установленные между ними связи. Команды Отобразить прямые и Отобразить все удобно использовать, если требуется найти другие таблицы и запросы, с которыми связана определенная таблица (или запрос).

^ Чтобы просмотреть связи, установленные для таблицы или запроса:

1. Выберите Схема данных в меню Сервис.

2. Для того чтобы отобразить все связи, определенные для текущей базы данных, выберите «Отобразить все» в меню Связи (или нажмите кнопку "Все связи" на панели инструментов).

Для того чтобы отобразить только связи, определенные для конкретной таблицы, выделите таблицу, а затем выберите «Отобразить прямые связи» в меню Связи (или нажмите кнопку "Прямые связи" на панели инструментов). Если требуется, добавьте эту таблицу (или запрос) в окно "Схема данных".

Команда «Отобразить прямые связи» добавляет в окно "Схема данных" все таблицы и запросы, непосредственно связанные с выделенной таблицей (или запросом).

Команда «Отобразить все» добавляет все таблицы текущей базы данных, для которых определены какие-либо связи.

^ Чтобы изменить существующую связь:

1. Выберите «Схема данных» в меню «Сервис».

2. Укажите на линию связи, которую следует изменить, и выполните двойной щелчок.

На экране появится окно диалога «Изменение связей».

3. Выберите параметры связи

4. Нажмите кнопку "ОК".


Чтобы удалить связь:

1. Выберите «Схема данных» в меню «Сервис».

2. Выделите линию связи, которую следует удалить.

3. Выберите «Удалить» в меню «Правка» (или нажмите клавишу DEL)


Чтобы удалить таблицу из окна "Схема данных":

1. Выберите «Схема данных» в меню «Сервис».

2. Выделите таблицу, которую следует удалить.

3. Выберите «Скрыть таблицу» в меню «Связи» (или нажмите клавишу

DEL).

Microsoft Access удалит указанную таблицу и все ее линии связи из окна "Схема данных". Эта операция влияет только на изображение связей; сама таблица и все ее связи останутся в базе данных, они просто перестанут отображаться в окне "Схема данных".


Контрольные вопросы:

  1. Типы отношений между таблицами?

  2. Что необходимо для обеспечения целостности данных?

  3. Поясните параметры «Каскадное удаление связанных записей»,

«Каскадное обновление связанных полей»?

Работа № 3

Запросы

Что такое запрос?

С помощью запроса можно задать вопрос о данных, хранящихся в таблицах. Запрос указывает Microsoft Access, какие именно данные интересуют пользователя.


С помощью запроса-выборки можно задать вопрос о данных, хранящихся в таблицах.

В процессе выполнения запроса-выборки Microsoft Access соберет данные, интересующие пользователя, в динамический набор. Динамический набор выглядит и ведет себя, как таблица, однако, таблицей не является; это динамическое представление данных из одной или нескольких таблиц, отобранных и отсортированных, как указано в запросе. При открытии запроса в режиме таблицы, а также открытии формы или печати отчета, основанного на этом запросе, динамический набор создается заново из текущего содержимого базы данных. Пользователь может вводить и изменять данные в полях динамического набора, как в таблице. Внесенные таким образом изменения заносятся в соответствующие базовые таблицы.

Примечание Динамический набор является обновляемым набором записей. Набор записей в Microsoft Access — это любая группа записей в таблице или запросе, которую можно рассматривать как отдельный объект. Если не указано иначе, результатом выполнения запросов, являются динамические наборы.


С помощью мастеров по разработке запросов можно упростить и ускорить процесс создания запросов.

Однако при создании большинства запросов можно обойтись без мастеров по разработке запросов. Далее рассматривается создание запроса без помощи мастера по разработке запросов.


Чтобы создать запрос без помощи мастера по разработке запросов:

1. Находясь в окне базы данных, укажите на корешок "Запрос" и нажмите кнопку мыши

2. Выполните двойной щелчок в области «Создание запроса в режиме конструктора».

3. На экране появится окно "Запрос на выборку", а поверх него — окно диалога «Добавление таблицы» со списком таблиц и запросов, хранящихся в текущей базе данных. Выберите таблицу «Список» и добавьте её в окно запроса.

4. Закройте окно «Добавление таблицы». На экране появится окно "Запрос на выборку".



Включение полей взапрос

Список полей, находящийся в верхней части окна запроса, содержит все поля, которые могут быть включены в текущий запрос. Если, в запрос включены несколько таблиц, окно запроса содержит список полей для каждой из них.

Чтобы включить поле в запрос с помощью мыши перенесите поле из списка полей в пустую ячейку в строке "Поле" бланка QBE.

Для добавления сразу нескольких полей следует нажать клавишу CTRL и, не отпуская ее, выделить по очереди все нужные поля, после чего перенести всю группу в строку "Поле" с помощью мыши. Для добавления непрерывной группы полей следует указать на первое поле и нажать кнопку мыши, затем нажать клавишу SHIFT и, не отпуская ее, указать на последнее поле и еще раз нажать кнопку мыши, после чего перенести всю группу в строку "Поле" с помощью мыши.

Повторяйте описанную выше процедуру до тех пор, пока все поля, которые следует включить в запрос, не будут помещены в бланк QBE.


С помощью мыши перенесите поля: Код, фамилия, имя, отчество, отдел, дата рождения из списка полей в свободную ячейку в строке "Поле".





Включение всех полей

Существует два быстрых способа включения в запрос всех полей таблицы или запроса: можно выделить все поля и перенести их в бланк QBE как одну группу или перенести в бланк QBE звездочку, расположенную вверху списка полей.

В результате применения этих двух способов получаются запросы, отличающиеся в следующем: во-первых, если впоследствии в структуру полей базовой таблицы (или запроса) будут внесены изменения, то в запросе, составленном вторым способом (с помощью звездочки), эти изменения будут отражены автоматически, а в запросе, составленном первым способом — нет; во-вторых, поля, включенные в запрос вторым способом нельзя использовать для сортировки записей и размещения условий отбора; в-третьих, на экран могут быть выведены либо все поля, перенесенные вторым способом, либо ни одно из этих полей.

Перенос всех полей как одной группы

Одним из способов включения в запрос всех полей таблицы или запроса является выделение всех полей и перенос их в бланк QBE как одной группы. Преимущество этого способа состоит в том, что поля, включенные в запрос таким способом, можно использовать для сортировки записей и размещения условий отбора.


Чтобы перенести все поля:

1. Укажите на заголовок списка полей и дважды нажмите кнопку мыши.
Если вы укажете на заголовок списка полей и дважды нажмете кнопку мыши Microsoft Access выделит все поля.

2. Установите указатель на любое из полей, выделенных в списке полей.

3. Перенесите поля с помощью мыши в бланк QBE.
Microsoft Access поместит каждое поле в отдельную ячейку в строке "Поле" бланка QBE.


Использование звездочки

Другим способом включения в запрос всех полей таблицы или запроса является перенос в бланк QBE звездочки (*), расположенной вверху списка полей, Преимущество этого способа состоит в том, что изменения в структуре полей базовой таблицы (или запроса) автоматически отражаются в запросе, составленном этим способом. Например, если в таблицу будет добавлено новое поле, то оно будет включено в запрос автоматически.

Перенесите звездочку в бланк QBE, чтобы включить в запрос все поля базовой таблицы или запроса.

При переносе звездочки в бланк QBE заполняется только одна ячейка в строке "Поле"; в нее вводятся имя таблицы, точка и звездочка. Например, в результате переноса звездочки из списка полей таблицы "Список" в бланк QBE будет введено "Список.*".

Примечание Поля, включенные в запрос с помощью звездочки, нельзя использовать для сортировки записей и размещения условий отбора.

Кроме того, можно просто ввести имя таблицы, точку и звездочку в строку "Поле" бланка ЯВЕ (например, Список.* или Дети.*).

Изменение порядка, вставка и удаление полей

После того как поля будут включены в запрос, легко изменить их порядок или удалить.

Чтобы переместить поле:

  1. Выделите поле: укажите на область маркировки столбца (над заголовком поля) и нажмите кнопку мыши.




  1. Не меняя положения указателя, нажмите кнопку мыши, а затем переместите столбец на новое место.


Чтобы вставить поле:

1. В списке полей выделите поле, которое следует вставить.

2. Перенесите поле из списка полей в нужный столбец бланка QBE. Существующее поле сдвинется вправо.


Чтобы удалить поле:

1. Выделите поле, которое следует удалить: укажите на область маркировки столбца (над заголовком поля) и нажмите кнопку мыши.

2. Нажмите клавишу DEL (или выберите ^ Удалить в меню Правка).


Совет Для удаления всех полей из бланка QBE следует выбрать Очистить бланк в меню Правка.


Изменение ширины столбца

Если ширина столбца в бланке QBE слишком велика или мала, то ее можно изменить. Кроме того, можно быстро изменить ширину столбца так, чтобы в нем стало полностью помещаться самое длинное значение в этом столбце.


Чтобы изменить ширину столбца:

1. В области маркировки столбца установите указатель на границу столбца, ширину которого следует изменить.

2. Для того чтобы уменьшить (увеличить) ширину столбца, перенесите его границу влево (вправо).


Чтобы быстро установить оптимальную ширину столбца:

В области маркировки столбца установите указатель на правую границу столбца, ширину которого следует изменить, и выполните двойной щелчок.

Если будет выделено несколько столбцов, то после выполнения описанных выше действий для каждого из этих столбцов будет установлена оптимальная для него ширина.

Если после установки оптимальной ширины в столбец будет добавлено значение, длина которого превышает текущую ширину столбца, то для того, чтобы это значение отображалось полностью, вам придется снова повторить описанную выше процедуру.


Сохранение запроса

Сохраненный запрос становится частью базы данных. Microsoft Access автоматически выбирает для него стандартное имя, однако, рекомендуется присваивать запросам более осмысленные имена.

Чтобы сохранить запрос и присвоить ему имя:

  1. Выберите Сохранить в меню Файл (или нажмите кнопку "Сохранить" на панели инструментов).

2. Если сохраняется новый запрос, введите имя для него, а затем нажмите кнопку "ОК". Имена запросов могут достигать 64 символов и содержать пробелы.


Одна база данных не может содержать таблицу и запрос с одинаковыми именами. При попытке присвоения запросу имени существующей таблицы на экране появится сообщение с предложением указать, следует ли заменить эту таблицу. В случае положительного ответа Microsoft Access заменит таблицу запросом, в результате чего содержимое таблицы будет потеряно.


Режимы окна запроса

Окно запроса может находиться в одном из режимов: режиме конструктора, режиме таблицы, режиме SQL, режиме предварительного просмотра, режиме сводной таблицы, сводной диаграммы.

^ Режим конструктора предназначен для создания новых и изменения существующих запросов. При создании запросов в этом режиме используется механизм запросов по образцу (QBE).

^ Режим таблицы следует использовать для просмотра данных, отобранных запросом.

В режиме предварительного просмотра данные выглядят на экране так, как они выглядели бы, будучи напечатаны.

Используйте режим SQL для ввода инструкций SQL, предназначенных для создания или изменения запроса.


При создании запросов в режиме конструктора используется механизм запросов по образцу (QBE). С помощью QBE можно создавать запросы, перенося поля из списков полей, расположенных в верхней части окна запроса, в бланк QBE, расположенный в нижней части окна. Каждый столбец в бланке QBE содержит сведения о поле, включенном в запрос.

Кнопки на стандартной панели инструментов окна запроса вызывают команды, которые используются при разработке запросов.

Отображение имен таблиц в бланке QBE

Если в запрос включены несколько таблиц, может быть удобно, если в бланке QBE будут отображены имена этих таблиц.


Чтобы отобразить имена таблиц в бланке QBE:

Выберите Имена таблиц в меню Вид (или нажмите кнопку "Им таблиц" на панели инструментов).

Microsoft Access добавит в бланк QBE строку "Имя таблицы". При переносе поля в строку "Поле" в строке "Имя таблицы" будет автоматически отображаться имя соответствующей таблицы.


Просмотр динамического набора

После того как создание запроса будет завершено, можно приступить к просмотру динамического набора, являющегося результатом выполнения этого запроса. Проще всего просмотреть динамический набор в жиме таблицы.


Чтобы просмотреть динамический набор:

1. Выберите Режим таблицы в меню Вид (или нажмите кнопку "Режим таблицы" на панели инструментов). Microsoft Access выведет на экран полученный динамический набор


Для изменения запроса выберите Конструктор в меню Вид (или нажмите кнопку "Конструктор" на панели инструментов). Внесите необходимые изменения в бланк QBE, а затем снова выберите Таблица в меню Вид, чтобы просмотреть новый динамический набор.


Для просмотра и изменения динамического набора после сохранения и закрытия запроса следует снова открыть запрос в режиме таблицы: выбрать корешок "Запрос" в окне базы данных, выделить нужный запрос, а затем нажать кнопку "Открыть". При каждом открытии запроса Microsoft Access снова выполняет запрос и отображает полученный динамический набор в режиме таблицы.


Изменение данных

Несмотря на то что Microsoft Access позволяет просматривать и редактировать динамический набор в режиме таблицы, для ввода и изменения данных может быть удобнее использовать форму, поскольку в форме можно использовать различные средства, недоступные в режиме таблицы. Например, в форме можно разместить список или поле со списком, которые позволяют не вводить значения, а выбирать их из списка.


Выбор порядка сортировки

Гораздо удобнее просматривать динамический набор, полученный в результате выполнения запроса, если записи в нем отсортированы. Записи можно отсортировать по алфавиту или в числовом порядке. Если в форме, отчете, списке или поле со списком требуется изобразить отсортированные данные, то следует создать запрос, выполняющий сортировку данных, а затем использовать этот запрос в качестве источника данных для формы, отчета, списка или поля со списком.


Чтобы выбрать порядок сортировки:

1. Установите указатель в ячейку "Сортировка" под полем, значения в котором следует отсортировать, и нажмите кнопку мыши, а затем нажмите кнопку раскрытия списка в этой ячейке.

2. Выберите "По возрастанию" (0 - 9, "А*' - "Я") или «по убыванию» (9 - 0, "Я" - "А") из этого списка.


Порядок сортировки можно задать сразу для нескольких полей. Порядок обработки полей определяется их положением в бланке QBE: сначала сортируются значения в крайнем левом поле и далее слева направо.

Для сортировки нельзя использовать МЕМО и OLE-поля.


Пример:

  1. Включите в бланк QBE следующие поля:

Код, Фамилия, Имя, Отчество, Отдел, Дата рождения, Член профсоюза.

  1. Перенесите поле Отдел в первый столбец бланка QBE/

  2. Выполните сортировку по полю Отдел.

  3. Просмотрите результат.

  4. Вернитесь в Режим конструктора и добавьте сортировку по полю код.




Определение условий отбора

Microsoft Access позволяет определить условия, которым должны удовлетворять записи, которые следует включить в динамический набор при выполнении запроса. Например, если в динамический набор требуется включить только сотрудников, работающих в плановом отделе, следует определить условие, отбирающее записи, у которых поле "отдел" содержит значение "плановый".

Условия отбора вводятся как выражения. Выражение указывает Microsoft Access, какие записи следует включить в динамический набор при выполнении запроса. Выражения могут быть простыми (например, "плановый") или сложными (например, "Between 1000 And 5000").

Для того чтобы создать выражение, следует ввести его непосредственно в бланк QBE или использовать построитель выражений. Построитель выражений позволяет выбрать компоненты выражения из списка, а затем составляет из них готовое выражение.


Чтобы определить условие отбора для поля с помощью построителя выражений:

1. Установите указатель в ячейку "Условие отбора" в бланке QBE, в которой следует определить выражение, и нажмите кнопку мыши.

2. Нажмите кнопку "Построить" на панели инструментов. На экране появится окно диалога Построитель выражений.




Чтобы определить условие отбора значений в поле путем ввода выражения:

'1. Введите нужное выражение в ячейку "Условие отбора", соответствующую данному полю.

Совет. Для того чтобы увеличить размеры области для ввода выражения, перейдите в нужную ячейку бланка QBE и нажмите клавиши SHIFT+F2.


Ввод выражений

Microsoft Access предоставляет пользователю большую гибкость при вводе выражений. Например, для отбора записей, у которых поле "Отдел" содержит значение "Плановый", годится любое из приведенных ниже выражений:

Плановый

"Плановый"

="Плановый"

После завершения ввода выражения — нажатия клавиши ENTER или перехода к другой ячейке бланка QBE — оно будет автоматически преобразовано к стандартной форме. Например, стандартной формой для перечисленных выше выражений является "Плановый".


В следующей таблице приведены примеры выражений, которые можно использовать в качестве условий отбора.

Выражение

Стандартная форма

Отбирает записи, которые

Иванов

"Иванов"

Содержат значение "Иванов"

100

100

Содержат значение 100

>15000

>15000

Содержат значение, большее 15000

<=30-янв-93

<=#30.01.93#

Содержат дату 30-янв-9 или более раннюю

"Красный маяк"

"Красный маяк"

Содержат значение

"Красный маяк"

Between 15-мар-94 And

30-мар-94

Between #15.03.94# And

#30.03.94#

Содержат даты между 15-мар-94 и 30-мар-94, включительно


Ввод значений для полей разных типов

Довольно часто запросы используются для отбора записей, которые содержат определенное значение в одном из полей, например, фамилия "Нахимов" или код сотрудника 23. Способ ввода значений в строку "Условие отбора" бланка QBE зависит от типа анализируемого поля, которое может быть числовым, счетчиком, денежным, даты/времени, текстовым или логическим.


Ввод чисел

В числовые и денежные поля и поля-счетчики вводятся цифры и (если требуется) десятичный разделитель. Ни в коем случае не следует вводить денежные символы и разделители тысяч. Например, для отбора значений, меньших 1 000 р., в денежном поле "Оплата" таблицы "Оплата" базы данных можно использовать следующее выражение:

<1000.


Ввод дат

Даты и время в поля даты/времени можно вводить практически в любом допустимом формате даты и времени. Наличие символов #, которые помещаются с обеих сторон значения, чтобы указать, что оно является датой, не является обязательным. Например, для отбора дат, более ранних, чем l6-янв-94, годится любое из приведенных ниже выражений:

<16 января 1994

<1/16/94

<16-янв-1994

<16.01.94


Ввод текста

При вводе текстовых значений следует просто ввести нужное значение. При этом можно использовать как прописные, так и строчные буквы (например, значение "Плановый" эквивалентно значению "плановый").


Ввод логических значений

Для того чтобы найти значение "Да", можно ввести "Да", "Истины "Вкл" или "-1".

Для того чтобы найти значение "Нет", следует ввести "Нет", "Ложь", "Выкл" или "0".


Исключение полей из динамического набора

То, что поле включено в запрос, не означает, что оно будет включено в динамический набор. Например, если требуется получить список сотрудников планового отдела, необязательно включать в динамический набор название отдела.


Для того чтобы указать, должно ли данное поле быть включено в динамический набор, следует установить или снять соответствующий ему флажок "Вывод на экран". По умолчанию, этот флажок автоматически устанавливается для всех полей, т.е. все поля помещенные в бланк QBE, включаются в динамические набор.


Чтобы исключить поле из динамического набора:

1.Снимите флажок "Вывод на экран", соответствующий этому полю.


При разработке запроса, который планируется использовать в качестве базового для формы или отчета, необходимо включить в динамический набор поля, с которыми будут связаны элементы управления.

Примечание Поле, исключенное из динамического набора, становится крайним правым в бланке QBE после сохранения запроса и его повторного открытия в режиме конструктора. Изменение положение этого поля не оказывает влияние на полученный динамический набор.

Добавле ние и удаление таблиц

Довольно часто запросы используются для отбора данных сразу из нескольких таблиц. Находясь в режиме конструктора запросов, в любой момент можно добавить в запрос дополнительные таблицы.


Чтобы добавить таблицу в запрос:

1. Находясь в режиме конструктора, выберите «Отобразить таблицу…»: меню Запрос (или нажмите кнопку «Отобразить таблицу…» на панели инструментов).


Чтобы удалить таблицу из запроса:

1. Находясь в режиме конструктора, выделите таблицу, которую следует удалить.

2. Нажмите клавишу Del.






Скачать 411,07 Kb.
Дата конвертации04.12.2013
Размер411,07 Kb.
ТипПрограмма
Разместите кнопку на своём сайте или блоге:
rud.exdat.com


База данных защищена авторским правом ©exdat 2000-2012
При копировании материала укажите ссылку
обратиться к администрации
Документы